Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

CS:S Crash

Discussion in CS:S Custom Maps started by JJeezery Dechamp, Feb 10, 2013

  1. Feb 3, 2012
    Posts
    This happened twice on the mg server where the CS:S just crashes and the other servers are fine. In console it says that the player timed out. This happens to everyone on the server and none of us know what's going on. :struggle:
  2. Nov 11, 2011
    Posts
    Yep, was there. Sever went from like 20 people to like 5 people. Everyone's game crashed at the same time.
    • Like Like x 1
    • Jun 11, 2012
      Posts
      This happened to me too. Actually I saw every player just drop and leave (timed out) except me and I was the only player there until they all joined, but then CS:S crashed to desktop with no error. Upon coming back this seems the same issue with other players. Also it happened to me all three time I joined MG, it just crashed to desktop. So I decided to check ZE and that was fine, this was just MG.
      • Like Like x 1
      • Sep 14, 2008
        Posts
        Apparently this is happening on Office course. It gave me an error that said Bad challenge. @Haplo @Josh @retslag1
      • May 25, 2012
        Posts
        Any map specifically? Do you have models, effects, etc. replaced? Asking because I've had this issue as well lately before and after the CS:S update. :dontknow:


        Edit: I'm late, Whoops.
      • Nov 11, 2011
        Posts
        Office course. I doubt 15 people had models replaced. But even if they did, there shouldn't be any server consistency enabled.
      • May 14, 2011
        Posts
      • May 25, 2012
        Posts
        Yeah, I didn't exactly read "This happens to everyone" bit in the original post. My fault.

        But I've been having issues where I can't myself play specific maps without the game crashing lately. It would've helped to pinpoint the issue had it been something replaced... Oh well.
      • Nov 11, 2011
        Posts
        I have models and materials from every possible source game, custom ones, ripped ones, etc. I can almost guarantee it's not something that's replaced. I think it might have to do something with a trigger killing an entity that doesn't exist or something. I'll take a look at it when I'm bored.
      • Feb 21, 2007
        Posts
        does this only happen on office course map?
      • Jun 11, 2012
        Posts
        It happened minutes after we switched from mg_ski to office course. I'm not sure if when the map changed the issue still existed or not but the server and game were fine up to that point.
      • Sep 14, 2008
        Posts
        We played a few different maps yesterday and everything was fine.
      • Nov 11, 2011
        Posts
        Yep. It happened when you have to jump over the electrified water. I'm looking at the file atm and will let you know if I see the problem.
        Post Merged, Feb 11, 2013
        Unfortunately, there doesn't seem to be anything out of the ordinary missing:

        [IMG] [IMG]

        I did see this near the spawn area where the crash usually occurs (right before the electrified water):

        [IMG]

        I am not familiar with this "speedmod" or whatever. A quick google search reveals not a lot. This could be the issue. Any mappers want to chime in?
      • May 31, 2012
        Posts

        As far as I am aware from using it in almost every map I've made, it should cause no problems at all.
        • Informative Informative x 1
        • Nov 11, 2011
          Posts
          I don't normally decompile maps but are missing filter activators a normal occurrence (something like the ladder texture being turned into nodraw texture)? I doubt that would cause any crashing issues but heh, worth a shot. Nothing else sticks out.
        • May 31, 2012
          Posts
          That is caused by decompiling. I don't know about the filters, though, but I doubt that would cause any problem; at maximum it would just let people/things/whatever not allowed to do something to do it, but I doubt that something that acts that way would cause a game crash on clients and not on the server itself.
        • Jan 11, 2011
          Posts
          This sounds like the problem Eddie had on Hypernova, with many people crashing on the map. This ended being the result of the laser entities, that had to be completely removed and replaced with particles.

          Have you noticed if most players crash on X location? A VISleaf where they start loading the VISleaf containing the lasers (if there are any)?
          The Laser-Entity is the only one I have seen (so far) crashing only some people, on some maps.
        • May 31, 2012
          Posts
          It could be, but I believe this map is already pretty old and it wouldn't have gone unnoticed. I think it has to do with the latest update; the other day joining another server, after mapchange, 4 or 5 players out of about 20 or 30 crashed, myself included.
        • Nov 11, 2011
          Posts
          Well, I did some tests and turned off somethings and turned on somethings in the visgroups. It's definitely an entity and it happens near the path_tracks (room with the moving walls) and in the laser room where you have to time the jump. Removing them doesn't crash the map anymore. Downloaded the original one off GB and it only crashed at the laser-room. I believe @Kaemon is indeed correct. It has something to do with the last update, almost damn positive. I'd say remove the map for now until we can figure out what exactly changed, @retslag1 .
        • May 20, 2011
          Posts
          This kind of reminds me of my Battlefield 2 times, where account spoofing was used to crash everyone to their desktop. Except, I have noticed this in the past (only on MG /w mapchange) and figured I was the only one encountering this problem, plus a box with "hl2.exe stopped working...".

          I'm no mapping guru, but I have never experienced 75/100 of the players getting crashed to their desktop on office_course. Than again, I haven't played MG since the new update.