Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

func_breakable issue

Discussion in Mapping Discussion started by KratosMafia, Nov 7, 2012

  1. Aug 21, 2012
    Posts
    So I am getting this issue
    func_breakable (func_breakable) at (205.500 -1478.500 114.560) using obsolete or unknown material type.

    I searched through all my func_breakable and could not find one at those cords. And idk if you can search for cords or else I would do that. Anyone know what could be going on?

    This is for CS:GO

    Also. On map load how do I do like "Map ported by (Name)" and such.
    KratosMafia, Nov 7, 2012 Last edited by KratosMafia, Nov 7, 2012
  2. May 15, 2011
    Posts
    For the map load you use a server_command.

    And unless you give us your map so we can check, we can't help you for dick, or atleast I can't, about the func_breakable. Otherwise, material would mean you entered a material type for the breaking animations/shit that doesn't exist.
  3. Oct 17, 2011
    Posts
    What texture did you use and what material type did you use in func_breakable?
  4. Aug 21, 2012
    Posts
    That is the thing. I can not find the function_breakable it is talking about. So everything is working only get that error. Which is preventing me from making it public I believe.
    If you're on the server then you can download the map and join. But you can not rejoin.
    [MM] Sending reservation request to (server ip)
    [MM] Sending reservation request to (server ip)
  5. May 15, 2011
    Posts
    Not the .bsp, we need the .vmf. If you let us have that, we can also go through the map and help find the issue. Right now it's just a geussing game since you're not providing screenshots, videos or the map in its .vmf file format.
  6. Oct 17, 2011
    Posts
    It shows coordinates next to the error in CSS console when you load the map. Copy the coordinates, remove the ( ) and The commas and paste it in hammer in view> go to coordinates. This happened to me a lot too. You may have probably placed a wood texture with a metal material breakable type. You can change that by going to the options in the func_breakable and put the right material type for it.
    I hope this is your answer or else, I'm stupid.
  7. Aug 21, 2012
    Posts
    haha found it. Was a tiny little glass in awall that is why was hard to find. Thanks. That helped ^-^
    • Like Like x 2
    • Jan 11, 2011
      Posts
      The problem was fixed, and its for CS:GO while I do map for CS:S...
      However, wanted to mention that, even if not aesthetically nice if you happen to look at the console when the map is loaded, that error doesn't give any futher problems on CS:S, and probably doesn't on CS:GO neither.

      And, seeing how Valve didn't change that much from a game engine to the other apart from adding a couple of entities, I think the error happens for the same reason, wich is the one shown in console: Using an obsolete or unkwon material type. This happens (in CS:S, just assuming is the same for GO) when you chose the material inside the func_breakable propierties to decide what kind of chunks/debris it will generate on broken. We all have seen Glass, Wood, Metal or Rocks (and those are pretty much the only working ones), but the editor allows you to select materials that don't work on CS:S like "Flesh", "Alien Flesh", "Computer/Electronics" or things like that. When those are selected, the error will appear in console, and when the breakable is broken it will make no sound (no glass/wood/metal/rock), and I believe it will show either Wood debris or not debris at all (not sure right now).

      If you don't mind that error line apearing in console it can be used to make "flesh" breakables (neutral/void in reality) if you don't want your monsters breaking into Wood or Glass (like Mako Reactor's Sephiroth breaking into Glass)
      • Informative Informative x 1
      • Aug 21, 2012
        Posts
        So now I am having an issue with leaks. It is really weird because I do not understand it. I put skybox all around my map.
        Then I go to load pointfile and the red line will go like straight through the middle of the skybox outside of it?
        http://gamebanana.com/threads/180589
        Exactly like this guys. I can not figure out a fix??
        remade the skybox acouple of times. and even covered the outside of it with nodraw.

        If someone could help that would be awesome. Thanks.
      • Feb 27, 2012
        Posts
        Like Dirtbag said, we would be able to figure out the problem if you link us the VMF file.

        The only other thing i can think of off the top of my head is that if you are using skip and hints for optimization, there could be a leak with one of them. I don't know much about optimization, but i remember the last time i tried, i gave up because of the leaks i kept causing :razz:
      • May 15, 2011
        Posts
        Oh that's nice. Like this guys. So I've been compiling and recompiling a map that isn't even yours. Useful. Really useful. My bad for not reading or noticing the dates though. But ya, we really need the .vmf, without that, we can't do shit but look stupid at you. Seriously what do you want us to do? Wish it away? Ask Luffaren the mapping magician to make your problems disappear with just a flick of his crooked cock wand.
        • Like Like x 1
        • Funny Funny x 1
        • Feb 27, 2012
          Posts
          So I'm not the only one that compiled the wrong map, then realized posts were 10 months old, then realized he said "Exactly like this guys..." after his link.
          • Like Like x 1
          • May 14, 2011
            Posts
            Firstly that guy used the hollow tool from what the screen shot shows. Secondly. Issues like a solid brush leaking happens because there is something wrong with the brush. Look at the brush along every plane. Is something like a brush entity going into it. Try completely re-making the brush. Try deleting sections of the map.

            Troubleshoot yourself.

            On second thought. I think I know what your problem is. You are loading an old point file. Delete the current point file, re-compile, then load it up again.
          • Oct 17, 2011
            Posts
            By looking at the third view of your skybox(bottom left), it seems like your skybox is not fully closed. Try checking your compile log to see what it tells you or post your compile log. Otherwise, send the .vmf like others said.
          • Aug 21, 2012
            Posts
            Alright will find someone to show the .vmf. Is hollow skybox bad or something? How am I supposed to do it. Every tut I watched they did hollow -32 so figured that is how to do it.
          • May 14, 2011
            Posts
            Yes it is.

            The best way to do it is to touch the walls edge to edge. Maybe someone can find you a screenshot if you don't understand.
          • Oct 17, 2011
            Posts
            Just make a big block surrounding your map and then go to tools>make hollow> -16 or -32. You can keep enlarging it every time it get small to your map and you need to add more stuff and delete it when your map is done. After that, make a new one and hollow it. I think I rusheit this pretty fast lol but I'll add you when I come back from church.
          • May 14, 2011
            Posts
            You will make vvis extremely long like this. This doesn't fix the issue. It simply covers it up (quite literally).
          • May 15, 2011
            Posts
            • Agree Agree x 2