Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Getting this problem from materials that keeps crashing my map

Discussion in Mapping Discussion started by Super Mario, Aug 20, 2012

  1. Oct 17, 2011
    Posts
    Hey guys, I just want to ask this simple question from my map where it crashes because of it. I am making materials like ffvii but different particles and wayy different but I looked up Hannibal and kaemon's forum to see how they made them and decided to create some for my map. The problem is when I compile the map, shoot the weapon_elite, it starts flying everywhere till it crashes the whole map. In console I got this error when I tested it with the heal material:
    Ignoring bonus angles (-1.#IND00,1.#qnano,180.000000) from vpgysics! (entity heal_elite)
    Any ideas how to fix this please?
  2. Jul 4, 2011
    Posts
    Do you mean particles?
  3. Oct 17, 2011
    Posts
    Nah i made a weapon_elite with a button in the front and a small 32 inch particle like ffvii but when I test them out. I shoot the gun while,it's constrained and it crashes the whole map.
  4. May 5, 2012
    Posts
    Ehm, have you remembered to make the particles kill itself so it disappeares or did i just misunderstood what you said :razz:? its something you have to do while making it :razz: atleast from what i know ^^[
  5. Oct 17, 2011
    Posts
    Yup it does get killed when it's fired. That's for materials like ice that don't follow the humans when they are spawned. I am talking about the weapon when it's constrained before getting picked up or anything. It has nothing to do with particles.
  6. May 31, 2012
    Posts
    Completely remake the button (save the outputs). Use the material 'npcclip' on the button, and set the 'Don't move' flag on. Reset time 1 sec. Check the parenting.
  7. Oct 17, 2011
    Posts
    Button had block light material cause it makes it not solid. Reset time was 3 and don't move flag is on. It only has one output that triggers a logic_relay with all the actions. The button was parented to the duel elite. It's a big from the physics I think. I put the error that console showed me at the first post when I shoot it.
    Is it because of copying and pasting it? Cause I did it on a test map first then put it on the original map.
  8. Dec 3, 2011
    Posts
    Mario, did u know killing entities more then once can caus map crashes? Dont know if u do that but i am just saying..
  9. Oct 17, 2011
    Posts
    Hmm I don't think it really does. Materials like ice on mako keep on respawning and getting killed every time they press the button and I am pretty sure cause they used env_entity_maker to spawn the template and making it get killed a few seconds after. Go to wordpress forum andyou'll find everything there.
  10. Feb 24, 2011
    Posts
    ..Killing entities which has already been killed / doesn't exist will with most certainty crash your map indeed.
    This env_entity_maker you're talking about is most likely the "spawner" for the materia/whatever WHICH kills itself ONCE after using it, not causing any crash.
  11. Aug 18, 2006
    Posts
    Killing a non existant entity WILL cause crashing issues.
  12. Nov 11, 2011
    Posts
    One, killing non-existing entities will cause an error output and crash. Two, blocklighttool does exactly that, block compile time light simulation. The npcclip brush is also invisible and non-solid...why not use that? Three, copying and pasting isn't an issue unless you have differing entities with the same name already in your map.
  13. Oct 17, 2011
    Posts
    Rofl you guys are not getting it. I never killed a non existing entity and never had a map crash because of this problem. I never killed entity maker also nor any particle systems when they were killed. My problem is the weapon elite that is flying everywhere when I shoot it. I'll send you guys a video and show you how it's doing. Sajak, block light is also non solid and used in all of the materias on mako and it was said by kaemon, so that's not the problem. Console is giving me an error from the weapon_elite.
  14. May 28, 2012
    Posts
    make sure that there isn't anything to cause it to move. Can you make a prefab of your current setup without changing it so us mappers can look at it?
  15. Nov 11, 2011
    Posts
    Send us the vmf. You're not explaining properly.
  16. Oct 17, 2011
    Posts
  17. Nov 11, 2011
    Posts
    Err I didn't think shooting a constrained elite would cause it to fly? Can you post pics of the "Flags" tab for all of your parented entities and the elites?
  18. Oct 17, 2011
    Posts
    All the elites have start constrained on and all the buttons have don't move flag and use activities on. The particles are parented to the elites and have their name and that's it. All the effects are done by the logic relay and env_entity maker.
  19. Nov 11, 2011
    Posts
    Then your best bet is, if you really want help, make a vmf with the elites and all your entities that are tied to it and upload it here. We'll test it out and let you know what is wrong. Capice?
    • Funny Funny x 1
    • May 14, 2011
      Posts
      heal_elite is the name of the elites I assume?