Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Light not working as intended

Discussion in Mapping Discussion started by Kloud, Dec 6, 2013

  1. Apr 3, 2013
    Posts
    Never had this problem before. So basically what's going on is, the map is dark, but the props show light. I think that the skybox is what causes this, but i'm not sure. So i'm hopefully getting some response from a guy who knows about this. Map is also supposed to be dark, but not pitchblack dark.

    I've tried these:
    • Recreating light_environment and adjusting it
    • Removing every light entity and just have light_env left
    • Removing every light entity, which of course, gave no sign of life to the map
    • Throwing rocks at a duck
    For compile log, this may be the reason, but I wanted to ask first before demolishing stuff -
    • Funny Funny x 1
    • Apr 9, 2012
      Posts
      IF you have a light in your map, make sure that you didn't accidentically added a negative number somewhere, as this sucks up all the lighting out of your map. Using an HDR skybox when not using HDR, I don't think that matters, but you could always ty using another one and see what it gives.
    • Apr 3, 2013
      Posts

      The number is not negative, and I've tried compiling with and without HDR. But I could try changing the number and post the results.
    • May 31, 2012
      Posts
      I'd assume you've changed it, but do you have the pitch set to 0 still?

      Do you have intensity values set on the lights?
    • Apr 3, 2013
      Posts

      The pitch level is set to -57 and intense values have not been set.
    • Feb 27, 2012
      Posts
      @Kloud
      • You should go to Map>Load Point File and see if you have a leak
      • Give us the entire compile log
      • Go to Map>Check For Problems
      • Make a light_environment that is completely default
      Also @JorisCeoen using an HDR skybox and compiling without HDR won't matter, i've never used HDR/Compiled with HDR on a release.
    • Oct 4, 2012
      Posts
      22:34 - Cuniczek: noob
      22:34 - Cuniczek: do you have leak?
      22:35 - Kloud [pF]: no
      22:34 - Cuniczek: 3d sky?
      22:35 - Kloud [pF]: ya
      22:35 - Cuniczek: do you have prop in it?
      22:35 - Kloud [pF]: uh
      22:35 - Kloud [pF]: i have a few ugly looking brushes in it
      22:35 - Kloud [pF]: and clouds
      22:35 - Cuniczek: disable shadows
      22:35 - Kloud [pF]: i think thats disabled
      22:35 - Kloud [pF]: unless i mistake'd
      22:35 - Cuniczek: then compile without 3d sky
      22:36 - Kloud [pF]: oh
      22:36 - Kloud [pF]: l0l
      22:36 - Cuniczek: try dat nao
      22:36 - Cuniczek: that compile part is nothing
      22:36 - Cuniczek: appears everytime
      22:37 - Kloud [pF]: guess wat
      22:37 - Kloud [pF]: My map crashed awhile back, and i forgot to put back disable shadows on the clouds
      22:37 - Kloud [pF]: lol
      22:37 - Cuniczek: dos it work?
      22:37 - Kloud [pF]: hold on
      22:37 - Kloud [pF] is now playing Counter-Strike: Source. Click here to join.
      22:37 - Kloud [pF]: it werks now
      • Funny Funny x 1
      • Winner Winner x 1
      • Mapping King Mapping King x 1
      • Artistic Artistic x 1
      • Apr 3, 2013
        Posts
        Map crashed awhile back while making the 3d skybox, and that crash made me forgot to disable the shadows on clouds, and that fixed it. Thanks cuni.
      • Apr 9, 2012
        Posts
        Kloud... How dare you xD no joke. Nice to hear it's fixed! Something I didn't think about, as I never experienced this myself. I'm smarter now