Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Lighting problem

Discussion in Mapping Discussion started by Super Mario, Mar 31, 2013

  1. Oct 17, 2011
    Posts
    I have never had this problem before. Everything in the map seems to be HDR while i'm compiling in LDR. The map is all bright on the inside and outside with no lighting at all. If anyone had this issue before, please help me solve it because i've been working on this map since summer and i don't know how to remove this brightness. I also added a few lights in some rooms and they don't work because the map is so bright. Here are some screenshots:

    [IMG]
    This is a fully closed room with no lights at all
    [IMG]
    Even props are so bright
    [IMG]
  2. May 31, 2012
    Posts
    Try typing mat_fullbright 0 in console. Try changing the lightgrid on the whole map to the nearest higher power of two (if 16, 32; if 32, 64 etc...).
  3. Jul 8, 2012
    Posts
    Do you get any compile time errors or have any leaks? When I did HL2 mapping, I've run into this a few times, which was a cause of either a leak or an error when compiling or running, can't remember since it's been a while.
  4. Oct 17, 2011
    Posts
    I have no errors at all. It could probably be the custom models that I downloaded from my friend that he built in hammer editor. As you look at pic 1, that farm is a prop_dynamic built from blocks. Otherwise, when I get back home, I'll do what enviolinador told me.
  5. May 15, 2011
    Posts
    Do you have a light_environment in your map?
  6. Feb 27, 2012
    Posts
    Make sure your VIS and RAD are set to "fast" and not "No". It looks like you have absolutely no environmental lighting at all.
    [IMG]

    Also, i'm not sure if it matters, but make sure you have an light_environment. I've never tried to run a map without one, so i'm not sure if you can have one or not for proper lighting
  7. May 14, 2011
    Posts
    Did you try what envi said? It looks like exactly that issue.

    EDIT: Oh you havent yet. Well thats your issue anyways.
  8. Nov 11, 2011
    Posts
    @Super Mario This should be it, I'm positive.
  9. May 31, 2012
    Posts
    I think it's more likely it is the lightgrid. He might have too much of a lightmap to be compiled and VRAD crashes, making the map fullbright. Of course, those two come by hand, but I don't think mat_fullbright 1 itself is the reason; it needs sv_cheats 1 to be activated so it shouldn't activate itself for no reason. Shouldn't.
    • Agree Agree x 1
    • May 14, 2011
      Posts
      Its activated itself for me once. It stays activated no matter how many times you re-compile if you mess up one compile until you turn it off.
    • May 31, 2012
      Posts
      That happens if you go from a fullbright map to a not-fullbright map in singleplayer. What I meant is that, normally, it shouldn't turn on by itself (if you compile without light it will obviously turn on).
    • Oct 17, 2011
      Posts
      If I type that command from enviolinador, will it go on forever even when I test it on a server?
      and @Dirtbag i never ran a map with no light_environment
      @Tony the Tiger!! :D everything is set to what you said. I'm using valve batch compiler now since it's wayyy faster. I had the lighting issue before I downloaded that custom compiler.
    • May 31, 2012
      Posts
      Select the whole map and set the textures' lightgrid to a higher power of two. It is 16 by default, so if you haven't changed it before, you should set it to 32. The command would only turn light back on if you had compiled lights, which doesn't seem to be the case (and, as you've stated that VRAD was set to compile, the only possibility is that it is crashing). Try it and, if it doesn't work, post the log to pastebin.
      • Like Like x 1
      • Winner Winner x 1
      • Oct 17, 2011
        Posts
        Problem solved thanks to enviolinador. I changed the light grid to 32 which was the problem.
        Also, thank u dirtbag, tony, sajak and ghost for your help :smile:
      • Nov 11, 2011
        Posts
        Good shit, so higher lightgrid reduces crashes? I thought it was the other way around. I am severely confused. :thinking:
      • May 31, 2012
        Posts
        Higher lightgrid means that the 'luxels' (pixelsish thing thong of the lightmap) are bigger, so the lightmap's quality decreases (it's a bit more diffuse) and you can store 'moar' (not exactly true, since the space assigned to it is static, I believe) things in it and make bigger maps. ZE maps (that are big) usually need those bigger lightgrids, otherwise they go full kaput due to the size.

        EDIT: Just a footer, lower lightgrid scales can be used in certain areas only to detail lighting, so I'd say it's a good idea to use those lower scales indoors (where objects are smaller and this will be more noticeable) and higher scales outdoors (where, simply put, nobody will really notice because lighting outdoors tends to be homogeneous).
        • Informative Informative x 1
        • Oct 17, 2011
          Posts
          I just tried that buttunes out, the whole map comes back to Fulbright if you make any brush 16. I guess I will need to make lights in certain dark areas. This is due to the size of the map and the amount of brushes.
          Edit: :shock: nvm that's the custom compiler that does not compile it good. I turned VRAD on by mistake in the VMPI
          Super Mario, Mar 31, 2013 Last edited by Super Mario, Mar 31, 2013