Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Raspberry Pi 2 Mumble Server?

Discussion in Networking started by Zenzr, May 27, 2015

  1. Jul 8, 2012
    Posts
    So I have it installed locally on my Pi 2 and it works (well I'm the only one that's tested it so far).

    What ports do I need to forward or whatever so others can connect?

    I am probably the most network challenged person on the face of the earth, so dumb you down explanations for me lol.

    Here's the guide I followed to get it running locally.
  2. Dec 30, 2006
    Posts
  3. Jun 11, 2012
    Posts
    The ports of which the services tells you to open. If it's linux, I'm quite amazed it doesn't just say something up front.
    Starting @Secprotocol Sex Mumble Chat Room
    Connecting over port 6969
    Not sexponding
    Not sexponding
    Quitting life
  4. Apr 9, 2007
    Posts
    Compile it yourself.
  5. Jun 4, 2006
    Posts
    What's it set to in your mumble-server.ini? Default is 64738.
  6. Apr 9, 2007
    Posts
    netstat -tunalp
    ss
  7. Jul 8, 2012
    Posts
    As far as I know I haven't changed it. Let me check. I think it's default and that sounds right. I guess I just need to look up how to forward it on my router then.
    Post Merged, May 27, 2015
    Also because I'm a noob and refuse to google information, what kind of bandwidth do I need to support a max of like 5-10 people on it?
  8. Jul 8, 2012
    Posts
    ur GB?
  9. Dec 30, 2006
    Posts
    Yes.
    • Programming King Programming King x 1
    • Oct 24, 2013
      Posts
      Make sure port 80 is open on all your devices and readily accessible.
    • Jun 4, 2006
      Posts
      http://wiki.mumble.info/wiki/FAQ/English#What_sort_of_bandwidth_will_I_need_for_the_server.3F
      http://wiki.mumble.info/wiki/Commercial_Hosting#Murmur_technical_requirements

      Values are based on the CELT codec, if you use OPUS it might be different.

      I'd just try the default setting and see if you get a bunch of dropped packets or not. If you do, try lowering the 'bandwidth' setting in the mumble-server.ini.
      • Programming King Programming King x 1
      • Apr 9, 2007
        Posts
        Default settings give client warnings.
      • Jul 8, 2012
        Posts
        Is this bad?
      • Jun 4, 2006
        Posts
        It means your server can't be registered as a public one on the giant list of mumble servers (which you probably don't want anyway, or you'll have a bunch of randoms joining). It'll also cause SSL verification issues, but to the average end user that just looks like a dialogue that pops up on first connect that they have to click OK on in order to join. For small, personal use with friends, it's nothing to worry about imo. You could bother with getting a free StartCom cert or similar if you don't want connecting users to get SSL verification errors on connect. A StartCom cert would only fix that however, and not the public server listing. For that the cert is required to include TLS, and StartCom certs do not include TLS. So if you wanted to fix both, you'd have to buy a SSL cert from somewhere - Comodo, RapidSSL, whatever - for about $10/year.
      • Apr 9, 2007
        Posts
        No, they warn about the bitrate being limited.
        • Informative Informative x 1