Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Sourcebans Setup

Discussion in Technical Support started by Who_er, Feb 7, 2013

  1. Jan 13, 2013
    Posts
    Im trying to setup sourcebans for my own server. I have the databse, and the webhost, but when i try to connect the actual server, i get an error message. Firewall is disabled, so i have all open ports.


    Error connecting (108.48.199.203:27015) Help

    The help link says:

    Which ports does the SourceBans webpanel require to be open?
    Submitted by Tsunami on Wed, 11/18/2009 - 14:20

    If your web panel shows Error Connecting for your game server when it is actually online,
    ask your web host to open UDP incoming from your game server port (usually 27015).

    If either the RCON console, Admin Rehashing or Kick-It does not work on your web panel,
    ask your web host to open TCP outgoing to your game server port (usually 27015).

    Use this small testing script to get more detailed debugging information. Open the php file and add your gameserver's ip and port as described in the comments.

    You should always check beforehand, if your gameserver banned your webserver's ip with listip in rcon. Remove it from the banned_ip.cfg and removeip IP via rcon.


    I have checked the ip's to make sure that they aren't banned, which they aren't. The test script they have, which i ran, gives this:

    [+] SourceBans "Error Connecting()" Debug starting for server 108.48.199.203:27015 (Server ip and port)

    [+] Trying to establish UDP connection
    [+] UDP connection successfull!
    [+] Trying to write to the socket
    [+] Successfully requested server info. (That doesn't mean anything on an UDP stream.) Reading...
    [-] Error getting server info. Can't read from UDP stream. Port is possibly blocked.

    [+] Trying to establish TCP connection
    [-] Error connecting #110: Connection timed out

    I don't know how to fix it, as i have tried everything.

    @Brian @Josh @Kyle

    Retslag said to tag you as you might know more on the issue.

    Thanks in advance,

    Who_er!
  2. Jun 4, 2006
    Posts
    Shouldn't be tagging us for something that has nothing to do with the maintenance of PF.

    You need to ask your host to allow connections from your gameserver IP / port. Open a ticket with them.

    Says right here...
  3. Jan 13, 2013
    Posts
    They already have. The ports are opened fully.

    Edit: Updated to a beta build of sourcebans with an extra option for people behind NAT. Seems to be working now (maybe).

    Same error, never mind D=
    Who_er, Feb 7, 2013 Last edited by Who_er, Feb 7, 2013