Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Trouble with new headset mic

Discussion in Technical Support started by SchwarzGeist, Sep 3, 2011

  1. Jan 7, 2009
    Posts
    I just got a pair of Steelseries Siberia V2s, and I've been trying to get the mic to work properly. The only problem is, every time I test it with the Steam tester thing, there's this fucking weird-ass reverb and it's pissing me off.
    Does anyone have any ideas what the problem might be, or what I could do to rectify it?

    I don't want to have spent 90 goddamn dollars on a headset to have a mic that doesn't work.
  2. Jun 30, 2011
    Posts
    I had a pair of astro a40s about 2 months ago and i restarted my computer and that seemed to make it all better although, they did fuck up entirely abotu a week later but it usually is just a temp fix.
  3. Jan 7, 2009
    Posts
    Well, the thing is I've tried it twice, on two different boots. Hasn't helped.
    I'm kind of looking for a more permanent solution, if anyone has one.
  4. Jun 30, 2011
    Posts

    Buy a new one? :grin:
  5. Apr 2, 2011
    Posts
    BUY MANLY HEADSET WITH MIC!!!! :thumbsup: or something cheap, I got mine at Rat Shack for 20 bucks, works fine... Remember you don't NEED something fancy...
  6. Feb 12, 2011
    Posts
    Pretty sure it's just steam that fucked up, it's known for that.
  7. Aug 20, 2011
    Posts
    I Agree With Flutter Lol I Use Dr.Dre HeadPhones LapTop And Mic Lol Expensive But Worth It :thumbsup: