Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

Weaponskins after Steampipeupdate - Problem

Discussion in Counter-Strike: Source started by -L-, Sep 10, 2013

  1. Mar 20, 2012
    Posts
    Hey,
    Ive downloaded this skin http://css.gamebanana.com/skins/48673 .

    As you can see there are 3 versions. Batman4 , Jennifer and Antipirate.
    I want the Jenifferversion so I copied them into custom/my_custom_stuff (the materials, sounds, script and models folder).
    The problem now is that I dont see the weaponskin when others have it equipped and I dont see the texture when I have it equipped. So only the worldmodel for the "dropped" version is working. Example: [IMG]


    However, I know tryed it with the Antipirate version and it works just normal. It has a different animation, but the same texture. With the Batman4 version I have the same problem as with the Jennifer version.

    Anybody got an idea how to fix this? Or can I somehow use the textures from Batman4 for the Jenniferskin without changing the animation?
  2. Mar 30, 2013
    Posts
    For v_models, it should be a texture problem, are you sure, you installed all good files in my_custom_stuff/materials/models/weapons ?
    And if i correctly understand, you can't see w_models of the weapon that other players hold. Normally w_models on the ground are invisible, and so you need to delete them, but in your case, it's a little strange.
    • Like Like x 1
    • Mar 20, 2012
      Posts
      Ye its the opposite. But I could live with other people just have normal dual elites if my own gun would have the skin.

      As you can see there are 3 types of worldmodels, I dont really know which is for what reason there but the files with "dropped" probably belong to the weaponmodel on the ground. So they are working, but the others not.
      If I would replace some of the v_ files I get a checksum error when I play and have a invisible skin, when I replace all with the working Antipirate version I have a different animation, which I dont want either.

      Fun thing is that all worldmodelsfiles in all 3 version have the same size but still only one works.


      [IMG]
    • Feb 27, 2012
      Posts
      Lots of people were having the same issue. I found this, it looks like a fix of it... I tried fixing the V4 ones, but i think it's in the model itself. This guy claims to have fixed it, so try it out. I'll let you know if it works if you haven't test it by the time i'm done.
      http://css.gamebanana.com/skins/48917
      Post Merged, Sep 10, 2013
      Alright, so i've figured it out. Download the one i linked above, install the materials/animations that you want, then go into the custom\my_custom_stuff\materials\models\weapons\v_models\9mm.Cutlass folder, then there are all the textures you can choose from, including black lagoon, which was the one you downloaded. Extract those files over top of the ones that are already there, and you get working textures.

      @-L-
      • Useful Useful x 1
      • Feb 8, 2013
        Posts
        Idk if im right, but the VMT is with the old path? check with notepad and if is wrong, change to the right path (happens when I installed the pokeball HE).
      • Mar 20, 2012
        Posts
        Alright Tony, nice ty. A little annoying that people can still download versions they cant use. Now I realize the thumb animation looks weird, its like 1 frame when you start shooting. But I dont care^^
      • Feb 27, 2012
        Posts
        Nah, my custom smiley face gloves were almost the EXACT same path, and they work fine... it was something do do with the model files. The guy just recompiled everything. One of the updates broke something.
      • Mar 20, 2012
        Posts
        I still get a checksum error now spamming my console. But its not really a problem mh.
      • Feb 27, 2012
        Posts
        What's the error? Copy pasta it.
      • Jul 14, 2010
        Posts

        This is for custom world models because of the update and no one uses them anymore really. I delete all my world model files so basically you see the skin when you're using it, but on other players it will show the normal skin. Livable for me since I can't take the spamming.

        The files would be in your models folder here: C:\Program Files (x86)\Steam\steamapps\common\Counter-Strike Source\cstrike\custom\my_custom_stuff\models\weapons

        Delete the ones with w_ but leave the v_ one's unless you want to keep the spam.
        • Useful Useful x 1
        • Jan 13, 2013
          Posts
          do world models no long work?
        • May 19, 2013
          Posts
          No, the world models are no longer work except the server is running sv_pure -1 command.
          • Informative Informative x 1
          • Mar 30, 2013
            Posts
            Delete all w_models and keep all v_models, that's all :smile:
          • May 19, 2013
            Posts
            Now the w_models are work again ! :grin:
            • Informative Informative x 2
            • Mar 30, 2013
              Posts
              Because of the new update ?
            • May 19, 2013
              Posts
              Yes.
              • Like Like x 1