Welcome to PlagueFest.com! Log in or Sign up to interact with the Plague Fest community.
  1. Welcome Guest! to interact with the community and gain access to all the site's features.

HELP, hammer troubles with water

Discussion in Mapping Discussion started by enano_salvaje, Dec 18, 2009

  1. Dec 17, 2009
    So I have been trying to figure out this literally all day. I keep having problems with the top layer of a lake in my map each time I compile it. The water is there in the game. It works fine when you're in it (looking merky and seeing the reflections up top), but the top is literally invisible when you're above the water and I can see the lake bottom.

    Now, the water will compile fine if I compile the map in halves and sections (telling me there is no specific region that is creating this problem). But as a whole, I can't get it to work.

    I am using func_detail linked to water. I have a water_LOD_control with the water. I have skybox all around the map. Also I have env_cubemaps linked specifically to the water textures.

    I have read over and over valve's commentary on water with the developer community, and I am at a loss.

  2. Dec 17, 2009
    Here a couple pics to hopefully clarify
    Above water
  3. Jul 5, 2008
    dont make it a function detail
  4. Dec 14, 2009
    Ye never use func_detail with water, and if that doesn't fix it do you have a leak in your map? If you do it will say at the top of the compile text *leaked* after cmpiling you can check for leaks by going to the mas tab and clicking load pointfile... Those are the two main reasons for water to bug, if that still doesn't work send me the vmf @ terrora@lapote.net and I will look at it, also you might wana look at what textures you are using... Some of them aren't made for the top surface of the water, so just watch out ^^

    Your map does look really nice though, awesome job so far!
  5. Dec 17, 2009
    So I took the water off from func_detail, and still same problem. The pointfile shows an odd "pointer" right outside the map, but connects to no ent or anything, just out in space.

    I'm gonna email it to you terrora. Models and everything but some sounds in it are from hl2 and css, so it should load fine.

    Thanks guys
  6. Dec 14, 2009
    Lol just from that tiny bit of text I know what your problem is I think, But I will see when you have sent it to me, when I have checked it I will emai lit back
  7. Jul 14, 2008
    all hail terrora ;D
  8. Dec 14, 2009
    Some awesome and really bad news, A) I fixed the problem which is cool however it came at a huge cost, EVERYTHING all of your bindings the ladders and so on are no longer bound, and all of the textures will be slightly off key now... What I thought the problem was when you said about the pointfile earliar was correct, you had an entity outside of your map in the void... ALWAYS make sure you delete stuff out of the void, that tiny error prob at start of map might have just cost you hours of work... If you want I can attempt to fix this problem without having to unbind everything but this might take a lot longer...

    To fix your error I simply selected the actual parts of the maps, and copied them into a new file... I also made the skybox in 3d skybox slightly bigger so no props were sticking outside of it... The problem with this is the map isn't pasted into the exact same place as it was copied >.> so all textured move, and for the unbindings I don't have a clue how that happened might be a bug... I will post you the dl link for fixed vmf however I will continue to try to fix the problem without having to unbind and retexture all... But to find the entity outside of map is like a needle in a haystack (One massive one) I should at least be able to do it w ith out unbinding everything, however retexturing isn't guarenteed... I am quite happy to spend another hour or two rebinding stuff and fixing some of the textures for you...

    One final note: I noticed a huge amount of errors in your compile, not all of them are significant just there are a lot lol, some of these were fixed when I unbugged the map / water... But we will see, dont worry too much about them

    Finally I will test your map tomorrow, as its nearly 3 am and I am too tired, from brief look I gave it, it did look amazing (yes I spent ages trying to fix the problem so I should have seen all of the map but I wasn't looking at the map just for the errors and fixes ^^.)
  9. Dec 17, 2009
    Dude, thank you so much for helping out. If you ever come to Colorado, I'll buy you a gallon of beer lol. I am about to check it out, but as for the textures, I am quite patient when it comes to re-texturing my map. As for those errors, it's odd, I never use to have all of those "too many lights styles on face" type of things until recently and just kept multiplying without any major changes... I don't really care as long as the map compiles fine.

    But yes, I will keep in touch with you, and again, thank you much!
  10. Dec 14, 2009
    hm no problem mate, and you can keep that gallon of beer for yourself or your mates :grin: Just saying hi is fine ^^

    Happy mapping

    Edit: I have had a go at fixing the map again without damaging the bindings and the textures, so far I have managed in the main map not to change any of the textures positions I believe and am about to compile to see for bindings...

    (the spot which is for you messing around and the skybox might have to have their textures redone because I couldn't put them back where they should have been... this only worked for the main map)

    Second Edit:
    Ah well I tried, but I didn't manage to solve the problem whilst keeping all the textures and bindings done up :/ so you will have to use the one I sent you before sorry couldn't manage ^^ Least water is fixed as you said good luck ^^